Rick's Simple CGI Script

I am running Perl 5.024000 on netbsd.

Summary of my perl5 (revision 5 version 24 subversion 0) configuration:
   
  Platform:
    osname=netbsd, osvers=7.0.1_patch, archname=x86_64-netbsd-thread-multi
    uname='netbsd ol 7.0.1_patch netbsd 7.0.1_patch (generic.201607220540z) amd64 '
    config_args='-sde -Duseshrplib -Duseithreads -Uusemymalloc'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='gcc', ccflags ='-O2 -pthread -I/usr/include -fwrapv -fno-strict-aliasing -pipe -fstack-protector -I/usr/pkg/include -D_FORTIFY_SOURCE=2',
    optimize='-O2   -pthread  -I/usr/include',
    cppflags='-O2 -pthread -I/usr/include -fwrapv -fno-strict-aliasing -pipe -fstack-protector -I/usr/pkg/include'
    ccversion='', gccversion='4.8.4', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678, doublekind=3
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16, longdblkind=3
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='gcc', ldflags ='-Wl,-rpath,/usr/pkg/lib -fstack-protector -L/usr/pkg/lib'
    libpth=/lib /usr/lib /usr/local/lib /usr/pkg/lib
    libs=-lm -lcrypt -lpthread
    perllibs=-lm -lcrypt -lpthread
    libc=/lib/libc.so, so=so, useshrplib=true, libperl=libperl.so
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E  -Wl,-R/usr/pkg/lib/perl5/5.24.0/x86_64-netbsd-thread-multi/CORE'
    cccdlflags='-DPIC -fPIC ', lddlflags='-shared  -L/usr/local/lib -L/usr/pkg/lib -fstack-protector'

/usr/pkg/lib/perl5/site_perl/5.24.0/x86_64-netbsd-thread-multi/usr/pkg/lib/perl5/site_perl/5.24.0/usr/pkg/lib/perl5/vendor_perl/5.24.0/x86_64-netbsd-thread-multi/usr/pkg/lib/perl5/vendor_perl/5.24.0/usr/pkg/lib/perl5/5.24.0/x86_64-netbsd-thread-multi/usr/pkg/lib/perl5/5.24.0.
I have CGI.pm version 4.32.